perpetuum mobile
05. 08. 2014. cucumber * ruby gem * bdd / tdd

Cucumber gem

Gemfile:

group :development, :test do
  gem 'rspec-rails', '3.0.2'
  gem 'factory_girl_rails', '4.4.1'
end

group :test do
  gem 'cucumber-rails', '1.4.1', :require => false
  gem 'cucumber-api-steps', :require => false
  gem 'shoulda-matchers', '2.6.2'
  gem 'database_cleaner', '1.3.0'
end

Generator:

rails generate cucumber:install

In /features/support/custom_env.rb :

require 'cucumber/api_steps'

Resources: